Back to overview
Downtime
Major Outage - Delacon Services (Resolved)
May 15, 2026 at 5:24am UTC
Affected services
portal.delacon.io
Call Tracking
Integrations
IVR
Speech Analytics
Voice Services / Telephony
Resolved
May 15, 2026 at 5:32am UTC
Resolved, under monitoring
Affected services
Created
May 15, 2026 at 5:24am UTC
From 2.45pm-3.05pm (AEST) all Delacon services were unavailable due to a critical issue with Delacon's database. Delacon engineers have conducted emergency maintenance and services have now been restored and are stable. Engineers are currently monitoring the database and associated services.
Affected services