Back to overview
Downtime

Major Outage - Reporting portals and website tracking

Apr 22, 2026 at 8:37pm UTC
Affected services
portal.delacon.io
Call Tracking

Resolved
Apr 22, 2026 at 10:27pm UTC

Services have been restored at approximately 7.18am AEST

Created
Apr 22, 2026 at 8:37pm UTC

Due to emergency maintenance by Delacon's internet service provider the reporting portals and website tracking are currently unavailable. ISP technicians are working on the issue as priority one. Further updates will be posted as more information becomes available.